YDPG18 FC on all default emulators

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

YDPG18 FC on all default emulators

DCXPIG
 Hello everyone, I rooted my Yinlips with Z4root v1.3, killed off N64oid with systemapp remover and installed v2.62, that runs all my rom images with no problem and slightly more smooth than the default/stock emu.  My Gboid, nesoid, snesoid, mame and all other default emus force close upon picking a rom.  I've played with most of the settings and have gotten nowhere but frustrated.  Forgot to mention, my PSX emulator still works fine as well, I've loaded and played Driver, Castlevania and a few others with no issues...  Anyone that can lend a suggestion would be welcomed.  
  Most recently I've wiped the cache as well as the apps and reloaded the system (after rooting) and added Marketplace again with no issues.  The reason I got to this point was simply to clean up the image, I don't know if I accidentally killed off something else somewhere or took a wrong turn on the reset before.  The os, wifi and aforementioned emu's run with no problem...  Trying Fruitninja and Angry Birds now...  Both work with no problem, no clue what I did.
  thanks much, and if anyone knows of any other dedicated resources to the system please post links, I'll do the same when I find them.

 
Reply | Threaded
Open this post in threaded view
|

Re: YDPG18 FC on all default emulators

ro0ody
Hi,
have a look at gthax's post here: http://yinlips-ydpg18-forum.2315615.n4.nabble.com/HELP-All-stock-emulators-crash-td4275022.html

I think he had a similar issue and was able to solve it.
Reply | Threaded
Open this post in threaded view
|

Re: YDPG18 FC on all default emulators

Shinkinrui
In reply to this post by DCXPIG
Another possible solution: http://boards.dingoonity.org/other-game-systems/new-opensource-console-announced-the-rg/msg34861/#msg34861

Quoted post from Elta:

"For some odd reason, the folks at Yinlips thought a good idea to copy some libraries, normally found in application APKs directly into /system/lib.
As far as I can tell, this is completely useless.
Now the problem is that the libraries in /system/lib have priority over ones found in APKs,
so when you update the emulator you use a new application with an old library... BOOOM!
To fix it, you will have to use a root mode file explorer and delete the useless library in /system/lib.

I can confirm that deleting these fix problems with updates:

Fpse:
libfpse.so

PSX4Droid:
libpsx.so

fpse 0.11 is now running just fine on my G18

Other libraries that look to me like they shouldn't be there:
(please note that I haven't deleted them myself yet)

Gensoid:
libgens.so

Snesoid:
libsnes.so
libsnes_comp.so

Ataroid:
libatari.so

nds4droid:
libn4dsdl12.so"

Hope this helps
Reply | Threaded
Open this post in threaded view
|

Re: YDPG18 FC on all default emulators

ro0ody
I actually had the very same issue after I've done a factory reset to get the Android Market unfiltered.
What I did is I uninstalled stock emulators with Titanium Backup and reinstalled them using .apks downloaded from the internet. And that's it.
My main problem was that I didn't back up with Titanium Backup prior to the reset - if I had done I probably would have been able to restore these emulators. Anyway, it's not that big of a deal since I have everything up and running now.
Reply | Threaded
Open this post in threaded view
|

Re: YDPG18 FC on all default emulators

DCXPIG
 Thanks for your comments guys, I had originally removed the apps by using a root-deleter and I think that's why I had trouble...  The libs were left behind so the programs always looked to the older librarys for reference and ended up fc'ing my machine...  Now that I've killed off the librarys mentioned on the previous post I have working emulators, thanks much.  I just read that 2.3 won't be available from Yinlips, let's hope there's  3rd party solution to the 3rd party machine.  It has alot of potential and works well as is, it'd be great to get it to where it was there.
Reply | Threaded
Open this post in threaded view
|

Re: YDPG18 FC on all default emulators

z_man3007
I have recently loaded custom firmware v1.1 that was posted few days ago on the dingoo-scene.  Since, I have loaded the custom firmware my Yinlips is very smooth.  The custom firmware doesn't come with any emulators and it is already rooted.  I had to basically re-install my emulators after loading the custom firmware.  I have also noticed the touch screen is more accurate while using the stylus.  Everything is running very smooth, thanks to the user who has Compiled and uploaded the firmware.  I had similar issues with uninstalling/installing emulators but not anymore.  Also, I like to mention one problems since I loaded the custom firmware, I don't call it a problem problem cause I had same issue with my android phone. After loading the custom firmware, in order for flash to work, you must uninstall the flash that comes with the custom firmware and download flash from Android market and install it.  I hope someone will come up with Gingerbread 2.3.  Thanks  
Reply | Threaded
Open this post in threaded view
|

Re: YDPG18 FC on all default emulators

DCXPIG
 I'm going to give that a shot tonight..  Just downloaded it and will get some time to play a little later, thanks for sharing your experience with the cfw.   Does anyone know if the new version (with the A9) has a different screen or same with multi?